常见问题

本节收集了使用者们的反馈,汇总成常见问题,在此感谢 Min 的使用者们,你们的反馈会让我们走得更远。

1、在已有项目中安装wxc-tab组件,不会编译panel,label组件。

该问题是由于安装组件时默认以index.wxc为入口文件进行编译,而tab组件比较特殊,其目录下还有panel, label这两个入口文件,未对其进行编译。该问题已经修复,如果遇到该问题,请升级 min 到 1.0.5-beta.1 及以上版本,升级命令:

$ npm install -g @mindev/min-cli

2、wepy与min的结合使用问题。

使用 wepy 时要求在微信开发者工具中关闭 es6=>es5,而 min 编译的输出文件是 es6 代码,直接冲突导致不可用。目前 min-cli 已增加 babel 配置项,编译时将文件转换成 es5。

第二个问题是在 wepy 项目中使用 wxc-toast 等组件时,由于 wepy 的 Page 对象被封装过,没有 selectComponent 等方法,通过 this.$wxpage.selectComponent 可调用该方法。

wepy与min的结合使用问题详细请参考: 结合 wepy 以及 重要提醒

3、min 打包时没有将 src 目录下的非单文件的静态资源拷贝到打包目录中。

该问题还在修复中,敬请期待。目前的解决办法是手动将静态资源目录拷贝到打包目录中去,或者将静态资源文件全部上传到 cdn 上。

4、style 标签中 import less 文件报错。

style 标签中 import less 文件, min 打包时默认是查找wxss文件,导致报错。该问题已在 min 1.0.5 版本中修复。